有效防护XSS,sql注射,代码执行,文件包含等多种高危漏洞的方法

可以有效防护XSS跨站攻击,sql注射,代码执行,文件包含等多种高危漏洞
有效防护XSS,sql注射,代码执行,文件包含等多种高危漏洞的方法
使用方法:
将waf.php传到要包含的文件的目录
在页面中加入防护,有两种做法,根据情况二选一即可:
a).在所需要防护的页面加入代码就可以做到页面防注入、跨站

1
require_once('waf.php');

如果想整站防注,就在网站的一个公用文件中,如数据库链接文件config.inc.php,来调用本代码。常用php系统添加文件

1
2
3
4
5
6
PHPCMS V9 \phpcms\base.php 
PHPWIND8.7 \data\sql_config.php 
DEDECMS5.7 \data\common.inc.php 
DiscuzX2   \config\config_global.php 
Wordpress   \wp-config.php 
Metinfo   \include\head.php

b).在每个文件最前加上代码具体做法是:在php.ini中找到 auto_prepent_file并修改为:

1
2
Automatically add files before or after any PHP document;
auto_prepend_file = waf.php路径;

下载地址: 百度云下载 官方下载 其它下载

未经允许不得转载:自由草 » 有效防护XSS,sql注射,代码执行,文件包含等多种高危漏洞的方法

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址